DCSIMG

tekvisa cannot find instrument

Moderators: Buck, Hiker, notnomis, Super Mod

tekvisa cannot find instrument

Postby allanmacdonald on Tue Aug 24, 2010 10:55 pm

Hi,

This is my first time on this forum.

I have a purchased copy of Wavestar for oscilloscopes (V2.3)n that I"ve been using for years without problems. I recently got a new computer (Vista) which doesn't have a built-in serial port and the old software didn't seem to be able to detect my Edgeport/4 USB to 4-serial port expander so I tried to download some new software to see if I could get the stuff to work.

I first downloaded the latest TekVISA software. It seems to run and detect the presence of the 4 ports but it doesn't actually send anything out the port. When I tried using Talker/Listener to send the IDN? command I see the following error on CallMonitor:

Time: 24/08/2010 7:19 PM 54.055 Duration: 0.0274s Command: viOpen(0x1bd7f78, "ASRL10::INSTR", 0, 5000, 0x0) - (0xbfff0011) "Error - Insufficient location information or resource not present in the system"

I see nothing out the serial port when I either set my scope (TEK3034) to debug mode or if I connect the serial port to another port and watch it using terminal software (TeraTermPro). The port works otherwise so the problem is not the port. I could send data to the scope using the terminal software and the scope detected my key strokes so the scope's OK as well. It also works on my old XP desktop without problems as well (albeit on a legacy serial port).

Does anybody know what might be going wrong or can help me? Thanks in advance.

Cheers,
Allan
allanmacdonald
 
Posts: 1
Joined: Tue Aug 24, 2010 10:35 pm

Re: tekvisa cannot find instrument

Postby Buck on Thu Sep 09, 2010 10:46 pm

TekVISA has some issues with serial connections. I would uninstall TekVISA and try using NI-VISA.
Tektronix Application Engineer
AFGs & AWGs
readme.1st readme.2nd
Buck
 
Posts: 746
Joined: Wed Jul 30, 2008 11:45 pm
Location: Beaverton, OR


Return to Other Product Technical Support